Hunter - Pet handling

Help us to help you!

Moderators: Admin, Gamemaster, Developer

User avatar
Muggle
Admin
Admin
Posts: 297
Joined: Tue Jan 20, 2015 12:18 am
Contact:

Hunter - Pet handling

Postby Muggle » Sat Jul 25, 2015 9:36 pm

User avatar
Series
Voice of Mekgineer Thermaplugg
Posts: 45
Joined: Thu Jan 22, 2015 1:58 am
Contact:

Re: Hunter - Pet handling

Postby Series » Sat Jul 25, 2015 11:59 pm

1 - COPIED

Hi Muggle, thanks for the post

Here's an issue with pets on friendly territory: https://www.youtube.com/watch?v=T5fwByQ ... e=youtu.be

They remain blue name despite attacking a hostile target in friendly territory. I believe this is currently possible with both Hunter & Warlock pets.

When an unflagged pet attacks a enemy target, it should flag both the pet and the owner as "PvP"


In that video above, it seems like pets did not drop target when the target entered stealth mode. This will require further testing though. Maybe I can get some footage later with ECG.


Thanks
Kadath
Voice of Archmage Arugal
Posts: 12
Joined: Tue Jun 02, 2015 2:41 am
Contact:

Re: Hunter - Pet handling

Postby Kadath » Sun Jul 26, 2015 2:56 am

2 - COPIED

When unmounting, the pet status icon (passive, etc) defaults to showing defensive, but the pet is still on whatever mode was last selected.
User avatar
Muggle
Admin
Admin
Posts: 297
Joined: Tue Jan 20, 2015 12:18 am
Contact:

Re: Hunter - Pet handling

Postby Muggle » Sun Jul 26, 2015 10:57 am

Evilmarge
Voice of Archmage Arugal
Posts: 17
Joined: Fri Jan 23, 2015 10:24 am
Contact:

Re: Hunter - Pet handling

Postby Evilmarge » Sun Jul 26, 2015 2:46 pm

2 - COPIED

If a warlock or hunter mounts up the pet should be on passive setting automatically. This is working fine. The pet is supposed to go back to the attack mode selected before mounting up. This is also working correct.

However once you dismount the visual is always set on defensive for my pet. Even though he's at passive, aggressive or defensive. This is no gamebreaking bug but it's quite annoying too see it every day.
User avatar
Muggle
Admin
Admin
Posts: 297
Joined: Tue Jan 20, 2015 12:18 am
Contact:

Re: Hunter - Pet handling

Postby Muggle » Sun Jul 26, 2015 2:52 pm

So the only issue is the pet's status visually not updating the moment you dismount?
Evilmarge
Voice of Archmage Arugal
Posts: 17
Joined: Fri Jan 23, 2015 10:24 am
Contact:

Re: Hunter - Pet handling

Postby Evilmarge » Sun Jul 26, 2015 2:58 pm

3 - COPIED

Yes. Atleast for hunters.

Speaking of warlock pets and mounts. If you attack a warlock his pet sometimes follow you while the warlock is still mounted and running away. It doesn't do anything but follow you. This is a bug for sure.
austere
Voice of Hogger
Posts: 1
Joined: Sat Mar 28, 2015 3:07 pm
Contact:

Re: Hunter - Pet handling

Postby austere » Tue Aug 04, 2015 1:14 pm

4 - COPIED

Ressing pet with the Call Pet ability.

How to reproduce:
Let your pet die. Either run away or let it "despawn". Use Call Pet, and your pet will instantly resurrect with 1 hp.

How it should work:
You should get an error message with something like "Your pet is dead" and be unable to use the ability. You should have to use Revive Pet instead.

Source:
http://wowwiki.wikia.com/Call_Pet?direc ... did=252831

"Call Pet (...) This will not work if your pet is dead"
User avatar
Muggle
Admin
Admin
Posts: 297
Joined: Tue Jan 20, 2015 12:18 am
Contact:

Re: Hunter - Pet handling

Postby Muggle » Sat Aug 15, 2015 11:08 am

@new and old hunters

I know there are some issues with the Hunter pet quests. Who knows more about it and can fill us in on the problems?
Haltia
Voice of Hogger
Posts: 2
Joined: Thu Mar 24, 2016 12:57 am
Contact:

Re: Hunter - Pet handling

Postby Haltia » Thu Mar 24, 2016 1:05 am

Hi! When boarding a ship the pet won't follow you to the ship even if you command it to do it. When the ship arrives at the destination and you try to call you pet it says "You already control a summoned creature" I found the only way to solve this is to re-log.

Return to “Bug Processing”

Who is online

Users browsing this forum: No registered users and 1 guest